net-im/ktp-text-ui: EAPI 6, pin slots
[gentoo.git] / dev-util / radare2 / radare2-0.10.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils
7
8 DESCRIPTION="Advanced command line hexadecimal editor and more"
9 HOMEPAGE="http://www.radare.org"
10 SRC_URI="http://www.radare.org/get/${P}.tar.xz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="ssl"
16
17 RDEPEND="
18         ssl? ( dev-libs/openssl:= )
19 "
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig
22 "
23 src_prepare() {
24         epatch "${FILESDIR}"/${PN}-0.9.9-nogit.patch
25 }
26
27 src_configure() {
28         econf \
29                 $(use_with ssl openssl)
30 }
31
32 src_install() {
33         # a workaround for unstable $(INSTALL) call, bug #574866
34         local d
35         for d in doc/*; do
36                 if [[ -d $d ]]; then
37                         rm -rfv "$d" || die "failed to delete '$d'"
38                 fi
39         done
40
41         default
42 }