dev-util/geany-plugins: Removed old.
[gentoo.git] / dev-util / pycharm-professional / pycharm-professional-2019.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils readme.gentoo-r1 xdg
7
8 DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
9 HOMEPAGE="http://www.jetbrains.com/pycharm/"
10 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
11
12 LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND=">=virtual/jre-1.8
17         dev-libs/libdbusmenu
18         dev-python/pip"
19
20 RESTRICT="mirror strip"
21
22 QA_PREBUILT="opt/${PN}/bin/fsnotifier
23         opt/${PN}/bin/fsnotifier64
24         opt/${PN}/bin/fsnotifier-arm
25         opt/${PN}/bin/libyjpagent-linux.so
26         opt/${PN}/bin/libyjpagent-linux64.so"
27
28 MY_PN=${PN/-professional/}
29 S="${WORKDIR}/${MY_PN}-${PV}"
30
31 src_prepare() {
32         default
33
34         rm -rf jre || die
35 }
36
37 src_install() {
38         insinto /opt/${PN}
39         doins -r *
40
41         fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
42
43         dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
44         newicon bin/${MY_PN}.png ${PN}.png
45         make_desktop_entry ${PN} ${PN} ${PN}
46
47         readme.gentoo_create_doc
48 }
49
50 pkg_postinst() {
51         xdg_pkg_postinst
52         gnome2_icon_cache_update
53 }
54
55 pkg_postrm() {
56         xdg_pkg_postrm
57         gnome2_icon_cache_update
58 }