5d0519372d5e7beabf11e00d923cf288e5e6791c
[gentoo.git] / dev-util / pycharm-professional / pycharm-professional-2017.2.4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils xdg-utils readme.gentoo-r1
7
8 DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
9 HOMEPAGE="http://www.jetbrains.com/pycharm/"
10 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
11
12 LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=virtual/jre-1.8
18          dev-python/pip"
19 DEPEND=""
20
21 RESTRICT="mirror strip"
22
23 QA_PREBUILT="opt/${PN}/bin/fsnotifier
24         opt/${PN}/bin/fsnotifier64
25         opt/${PN}/bin/fsnotifier-arm
26         opt/${PN}/bin/libyjpagent-linux.so
27         opt/${PN}/bin/libyjpagent-linux64.so"
28
29 MY_PN=${PN/-professional/}
30 S="${WORKDIR}/${MY_PN}-${PV}"
31
32 src_prepare() {
33         default
34
35         rm -rf jre || die
36 }
37
38 src_install() {
39         insinto /opt/${PN}
40         doins -r *
41
42         fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
43
44         dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
45         newicon bin/${MY_PN}.png ${PN}.png
46         make_desktop_entry ${PN} ${PN} ${PN}
47
48         readme.gentoo_create_doc
49 }
50
51 pkg_postinst() {
52         xdg_desktop_database_update
53         gnome2_icon_cache_update
54 }
55
56 pkg_postrm() {
57         xdg_desktop_database_update
58         gnome2_icon_cache_update
59 }