dev-python/pip: arm64 stable (bug #719946)
[gentoo.git] / dev-util / pycharm-community / pycharm-community-2020.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils readme.gentoo-r1 xdg
7
8 DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
9 HOMEPAGE="http://www.jetbrains.com/pycharm/"
10 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
11
12 LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+bundled-jdk"
16
17 RDEPEND="!bundled-jdk? ( >=virtual/jre-1.8 )
18         dev-libs/libdbusmenu
19         dev-python/pip"
20
21 RESTRICT="mirror strip"
22
23 QA_PREBUILT="opt/${PN}/bin/fsnotifier
24         opt/${PN}/bin/fsnotifier64
25         opt/${PN}/bin/fsnotifier-arm"
26
27 MY_PN=${PN/-community/}
28
29 src_install() {
30         insinto /opt/${PN}
31         doins -r *
32
33         if use bundled-jdk; then
34                 fperms -R a+x /opt/pycharm-community/jbr/bin/
35         else
36                 rm -r "${D}"/opt/pycharm-community/jbr/ || die
37         fi
38
39         fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
40
41         dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
42         newicon bin/${MY_PN}.png ${PN}.png
43         make_desktop_entry ${PN} ${PN} ${PN}
44
45         readme.gentoo_create_doc
46 }
47
48 pkg_postinst() {
49         xdg_pkg_postinst
50         gnome2_icon_cache_update
51 }
52
53 pkg_postrm() {
54         xdg_pkg_postrm
55         gnome2_icon_cache_update
56 }