6bcb19218d4c7acf253af5514540530d8a7fae7e
[gentoo.git] / dev-util / pycharm-community / pycharm-community-2017.2.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils readme.gentoo-r1
7
8 DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
9 HOMEPAGE="http://www.jetbrains.com/pycharm/"
10 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
11
12 LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=virtual/jre-1.8"
18 DEPEND=""
19
20 RESTRICT="mirror strip"
21
22 QA_PREBUILT="opt/${PN}/bin/fsnotifier
23         opt/${PN}/bin/fsnotifier64
24         opt/${PN}/bin/fsnotifier-arm"
25
26 MY_PN=${PN/-community/}
27
28 src_prepare() {
29         default
30
31         rm -rf jre || die
32 }
33
34 src_install() {
35         insinto /opt/${PN}
36         doins -r *
37
38         fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
39
40         dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
41         newicon "bin/${MY_PN}.png" ${PN}.png
42         make_desktop_entry ${PN} "${PN}" "${PN}"
43
44         readme.gentoo_create_doc
45 }