dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-util / ply / ply-2.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools linux-info
7
8 DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
9 HOMEPAGE="https://github.com/iovisor/ply"
10 SRC_URI="https://github.com/iovisor/ply/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15 IUSE="static-libs"
16
17 pkg_pretend() {
18         local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
19                 ~BPF_JIT ~HAVE_BPF_JIT ~BPF_EVENTS"
20
21         check_extra_config
22 }
23
24 src_prepare() {
25         sed -i "/^AC_INIT/c\AC_INIT(${PN}, ${PV}," configure.ac || die
26         eapply_user
27         eautoreconf
28 }
29
30 src_install() {
31         default
32         rm -f "${ED}/usr/share/doc/${P}/COPYING"
33
34         if ! use static-libs; then
35                 find "${D}" -type f -name '*.a' -delete || die
36         fi
37 }