dev-util/cmake: Bump to version 3.12.0. Removed old.
[gentoo.git] / dev-util / patchelf / patchelf-0.8.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=true
7
8 inherit autotools-utils
9
10 DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
11 HOMEPAGE="http://nixos.org/patchelf.html"
12 SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
13
14 SLOT="0"
15 KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
16 LICENSE="GPL-3"
17 IUSE=""
18
19 AUTOTOOLS_IN_SOURCE_BUILD=1
20
21 PATCHES=( "${FILESDIR}"/${P}-dash.patch )
22
23 src_prepare() {
24         rm src/elf.h || die
25         sed -e 's:-Werror::g' -i configure.ac || die
26         autotools-utils_src_prepare
27 }
28
29 src_configure() {
30         local myeconfargs=( --docdir="${EPREFIX}"/usr/share/doc/${PF} )
31         autotools-utils_src_configure
32 }
33
34 src_test() {
35         autotools-utils_src_test -j1
36 }