dev-python/click-default-group: keyworded 1.2.2 for ia64, bug #700918
[gentoo.git] / dev-util / patchbin / patchbin-20160208.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == 99999999 ]]; then
7         inherit git-r3
8         EGIT_REPO_URI="https://github.com/wine-compholio/wine-staging"
9         KEYWORDS=""
10 else
11         SHA="4ffcf184bb71c6c3512b3a8c144dcf4a3a76d23c"
12         SRC_URI="https://github.com/wine-compholio/wine-staging/archive/${SHA}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="amd64 x86"
14         S="${WORKDIR}/wine-staging-${SHA}"
15 fi
16
17 DESCRIPTION="Apply binary patches without git"
18 HOMEPAGE="https://github.com/wine-compholio/wine-staging"
19
20 LICENSE="LGPL-2.1"
21 SLOT="0"
22 IUSE="userland_BSD userland_GNU"
23
24 RDEPEND="
25         app-shells/bash
26         sys-apps/coreutils
27         sys-apps/gawk
28         sys-apps/grep
29         sys-apps/util-linux
30         sys-devel/patch
31 "
32
33 src_prepare() {
34         mv patches/gitapply.sh ${PN} || die
35         sed -E -i "s/(\.\/)?gitapply(\.sh)?/${PN}/g" ${PN} || die
36
37         default
38 }
39
40 src_install() {
41         exeinto /usr/bin/
42         doexe ${PN}
43 }
44
45 pkg_postinst() {
46         einfo "${PN} can optionally use dev-util/git to apply patches if installed."
47 }