dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-util / packer / packer-1.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit golang-vcs-snapshot
7
8 DESCRIPTION="A tool to create identical machine images for multiple platforms"
9 HOMEPAGE="https://www.packer.io"
10
11 EGO_PN="github.com/hashicorp/packer"
12 SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MPL-2.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18 DEPEND=">=dev-lang/go-1.11.0"
19
20 DOCS=( README.md CHANGELOG.md )
21
22 src_compile() {
23         cd "src/${EGO_PN}" || die
24         GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
25                 -v -work -o "${S}/${PN}" ./ || die
26 }
27
28 src_install() {
29         dobin packer
30
31         pushd "src/${EGO_PN}" || die
32         einstalldocs
33         insinto /usr/share/zsh/site-functions
34         doins contrib/zsh-completion/_packer
35         popd || die
36 }