dev-util/ply: Fix SRC_URI
[gentoo.git] / dev-util / ostree / ostree-2019.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools systemd
7
8 DESCRIPTION="Operating system and container binary deployment and upgrades"
9 HOMEPAGE="https://ostree.readthedocs.io/en/latest/"
10 SRC_URI="https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
11
12 KEYWORDS="~amd64 ~x86"
13 LICENSE="LGPL-2+"
14 SLOT="0"
15
16 IUSE="archive curl doc dracut gnutls grub http2 httpd introspection libmount selinux ssl soup systemd zeroconf"
17 RESTRICT="test"
18 REQUIRED_USE="httpd? ( || ( curl soup ) )"
19
20 COMMON_DEPEND="
21         archive? ( app-arch/libarchive )
22         app-crypt/gpgme
23         app-arch/xz-utils
24         curl? ( net-misc/curl )
25         soup? ( net-libs/libsoup )
26         dev-libs/libassuan
27         dev-libs/libgpg-error
28         dev-libs/glib:2
29         dracut? ( sys-kernel/dracut )
30         grub? ( sys-boot/grub:2= )
31         introspection? ( dev-libs/gobject-introspection )
32         ssl? (
33                 gnutls? ( net-libs/gnutls )
34                 !gnutls? ( dev-libs/openssl:0= ) )
35         >=sys-fs/fuse-2.9.2:*
36         sys-libs/zlib
37         libmount? ( sys-apps/util-linux )
38         selinux? ( sys-libs/libselinux )
39         systemd? ( sys-apps/systemd:0= )
40         zeroconf? ( net-dns/avahi[dbus] )"
41
42 DEPEND="${COMMON_DEPEND}
43         app-text/docbook-xsl-stylesheets
44         dev-libs/libxslt
45         doc? ( dev-util/gtk-doc )"
46
47 RDEPEND="${COMMON_DEPEND}"
48 BDEPEND="
49         dev-util/glib-utils
50         sys-devel/flex
51         sys-devel/bison
52         virtual/pkgconfig"
53
54 S="${WORKDIR}/lib${P}"
55
56 src_prepare() {
57         sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
58                 -i Makefile.in Makefile-man.am || die
59
60         eautoreconf
61         default
62 }
63
64 src_configure() {
65         local econfargs=(
66                 --enable-man
67                 --enable-shared
68                 $(use_with archive libarchive)
69                 $(use_with curl)
70                 $(use_with dracut)
71                 $(use_enable doc gtk-doc)
72                 $(use_enable introspection)
73                 $(use_enable http2)
74                 $(use_enable httpd trivial-httpd-cmdline)
75                 $(use_with selinux )
76                 $(use_with soup)
77                 $(use_with libmount)
78                 $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
79                 $(use_with systemd libsystemd)
80                 $(use_with zeroconf avahi)
81         )
82
83         unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
84         econf ${econfargs[*]}
85 }
86
87 src_install() {
88         default
89         find "${D}" -name '*.la' -delete || die
90 }