dev-util/meson: sync live ebuild
[gentoo.git] / dev-util / meson / meson-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{4,5,6} )
6
7 if [[ ${PV} = *9999* ]]; then
8         EGIT_REPO_URI="https://github.com/mesonbuild/meson"
9         inherit git-r3
10 else
11         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12         KEYWORDS="~amd64 ~x86"
13 fi
14
15 inherit distutils-r1
16
17 DESCRIPTION="Open source build system"
18 HOMEPAGE="http://mesonbuild.com/"
19
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 IUSE=""
23 RESTRICT="test"
24
25 DEPEND="${PYTHON_DEPS}
26         >=dev-util/ninja-1.6.0
27 "
28 RDEPEND="${DEPEND}"
29
30 python_test() {
31         ${EPYTHON} run_tests.py || die
32 }