dev-util/meson: 0.48.2 bump
[gentoo.git] / dev-util / meson / meson-0.47.1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{5,6} )
6
7 if [[ ${PV} = *9999* ]]; then
8         EGIT_REPO_URI="https://github.com/mesonbuild/meson"
9         inherit git-r3
10 else
11         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12         KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
13 fi
14
15 inherit distutils-r1
16
17 DESCRIPTION="Open source build system"
18 HOMEPAGE="http://mesonbuild.com/"
19
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 IUSE=""
23 RESTRICT="test"
24
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
26 RDEPEND=""
27
28 python_test() {
29         ${EPYTHON} run_tests.py || die
30 }
31
32 python_install_all() {
33         distutils-r1_python_install_all
34
35         insinto /usr/share/vim/vimfiles
36         doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
37         insinto /usr/share/zsh/site-functions
38         doins data/shell-completions/zsh/_meson
39 }