dev-util/meson: 0.37.1 version bump
[gentoo.git] / dev-util / meson / meson-0.37.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 PYTHON_COMPAT=( python3_{4,5} )
7
8 if [[ ${PV} = *9999* ]]; then
9         EGIT_REPO_URI="https://github.com/mesonbuild/meson"
10         inherit git-r3
11 else
12         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13         KEYWORDS="~amd64 ~x86"
14 fi
15
16 inherit distutils-r1
17
18 DESCRIPTION="Open source build system"
19 HOMEPAGE="http://mesonbuild.com/"
20
21 LICENSE="Apache-2.0"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND="${PYTHON_DEPS}
26         >=dev-util/ninja-1.6.0
27 "
28 RDEPEND="${DEPEND}"
29
30 DOCS=( authors.txt contributing.txt )