dev-util/meld: amd64 stable wrt bug #685254
[gentoo.git] / dev-util / meld / meld-3.20.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 PYTHON_REQ_USE="xml"
6 PYTHON_COMPAT=( python3_{5,6,7} )
7 DISTUTILS_SINGLE_IMPL=1
8
9 inherit gnome2 distutils-r1
10
11 DESCRIPTION="A graphical diff and merge tool"
12 HOMEPAGE="http://meldmerge.org/"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 RDEPEND="${PYTHON_DEPS}
20         >=dev-libs/glib-2.50:2[dbus]
21         >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
22         gnome-base/gsettings-desktop-schemas
23         >=x11-libs/gtk+-3.20:3[introspection]
24         >=x11-libs/gtksourceview-3.20.0:3.0[introspection]
25         >=x11-libs/pango-1.34[introspection]
26         x11-themes/hicolor-icon-theme
27 "
28 DEPEND="${RDEPEND}
29         dev-util/intltool
30         dev-util/itstool
31         sys-devel/gettext
32 "
33
34 python_compile_all() {
35         mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
36 }