dev-util/clair: remove old
[gentoo.git] / dev-util / makepp / makepp-2.0.99.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_PV=${PV/_}
7 MY_P="${PN}-${MY_PV}"
8 DESCRIPTION="GNU make replacement"
9 HOMEPAGE="http://makepp.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/2.1/${MY_P}.txz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
15 IUSE=""
16
17 DEPEND="dev-lang/perl:="
18
19 S=${WORKDIR}/${MY_P}
20
21 src_prepare() {
22         # default "all" rule is to run tests :x
23         sed -i '/^all:/s:test::' config.pl || die
24         sed -i 's/^  my $gzip =.*/  my $gzip = "";/' install.pl || die
25         default
26 }
27
28 src_configure() {
29         # not an autoconf configure script
30         ./configure \
31                 --prefix="${EPREFIX}"/usr \
32                 --bindir="${EPREFIX}"/usr/bin \
33                 --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
34                 --mandir="${EPREFIX}"/usr/share/man \
35                 --datadir="${EPREFIX}"/usr/share/makepp \
36                 || die "configure failed"
37 }
38
39 src_test() {
40         # work around https://bugzilla.samba.org/show_bug.cgi?id=8728
41         export CCACHE_UNIFY=1
42         ROOT= default
43 }