dev-util/*: Update Manifest hashes
[gentoo.git] / dev-util / lttng-ust / lttng-ust-2.6.5.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools versionator
7
8 MY_P="${P/_rc/-rc}"
9 MY_SLOT="$(get_version_component_range 1-2)"
10
11 DESCRIPTION="Linux Trace Toolkit - UST library"
12 HOMEPAGE="http://lttng.org"
13 SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0/${MY_SLOT}"
17 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
18 IUSE="examples"
19
20 DEPEND="dev-libs/userspace-rcu"
21 RDEPEND="${DEPEND}"
22
23 S="${WORKDIR}"/${MY_P}
24
25 src_prepare() {
26         if ! use examples; then
27                 sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
28         fi
29         eautoreconf
30 }