dev-util/lttng-modules: version bump
[gentoo.git] / dev-util / lttng-ust / lttng-ust-2.6.0_rc2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools
8
9 MY_P="${P/_rc/-rc}"
10 DESCRIPTION="Linux Trace Toolkit - UST library"
11 HOMEPAGE="http://lttng.org"
12 SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
17 IUSE="examples"
18
19 DEPEND="dev-libs/userspace-rcu"
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}"/${MY_P}
23
24 src_prepare() {
25         if ! use examples; then
26                 sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
27         fi
28         eautoreconf
29 }