ef98722f052e6096cb2f005abf1312f1bc41de8e
[gentoo.git] / dev-util / kyua / kyua-0.13-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Testing framework for infrastructure software"
7 HOMEPAGE="https://github.com/jmmv/kyua"
8 SRC_URI="https://github.com/jmmv/kyua/releases/download/${P}/${P}.tar.gz"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
13 IUSE="test"
14
15 # Tests fail
16 RESTRICT="test"
17
18 RDEPEND="
19         dev-db/sqlite:3
20         dev-libs/atf
21         dev-lua/lutok
22 "
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         test? ( dev-libs/atf )
26 "
27
28 src_install() {
29         default
30         rm -r "${ED%/}"/usr/tests || die
31 }