dev-util/kdevelop-php: 5.4.0 version bump
[gentoo.git] / dev-util / kdevelop-php / kdevelop-php-5.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 KDE_DOC_DIR="docs"
7 KDE_HANDBOOK="forceoptional"
8 KDE_TEST="true"
9 KMNAME="kdev-php"
10 VIRTUALX_REQUIRED="test"
11 inherit kde5
12
13 if [[ ${KDE_BUILD_TYPE} = release ]]; then
14         KEYWORDS="~amd64 ~x86"
15 fi
16
17 DESCRIPTION="PHP plugin for KDevelop"
18 HOMEPAGE="https://www.kdevelop.org/"
19 LICENSE="GPL-2 LGPL-2"
20 IUSE=""
21
22 BDEPEND="
23         test? ( dev-util/kdevelop:5[test] )
24 "
25 DEPEND="
26         $(add_frameworks_dep kcmutils)
27         $(add_frameworks_dep kconfig)
28         $(add_frameworks_dep kconfigwidgets)
29         $(add_frameworks_dep kcoreaddons)
30         $(add_frameworks_dep ki18n)
31         $(add_frameworks_dep kio)
32         $(add_frameworks_dep ktexteditor)
33         $(add_frameworks_dep kwidgetsaddons)
34         $(add_frameworks_dep kxmlgui)
35         $(add_frameworks_dep threadweaver)
36         $(add_qt_dep qtgui)
37         $(add_qt_dep qtwidgets)
38         dev-util/kdevelop-pg-qt:5
39         dev-util/kdevelop:5=
40 "
41 RDEPEND="${DEPEND}"
42
43 # remaining tests fail for some, bug 668530
44 RESTRICT+=" test"
45
46 src_test() {
47         # tests hang, bug 667922
48         local myctestargs=(
49                 -E "(completionbenchmark|duchain_multiplefiles)"
50         )
51         kde5_src_test
52 }