dev-util/shellcheck: version bump to 0.4.6
[gentoo.git] / dev-util / jarwizard / jarwizard-2.50.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit java-pkg-2 java-ant-2
5
6 DESCRIPTION="Takes the hassle out of creating executable JAR files for your Java programs"
7 SRC_URI="mirror://sourceforge/jarwizard/${PN}_${PV/./}_src.zip"
8 HOMEPAGE="https://sourceforge.net/projects/jarwizard/"
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~amd64 x86"
12 DEPEND=">=virtual/jdk-1.5
13                 app-arch/unzip"
14 RDEPEND=">=virtual/jre-1.5"
15
16 IUSE=""
17
18 S="${WORKDIR}/${PN}"
19
20 src_unpack() {
21         unpack ${A}
22         java-ant_bsfix_one "${S}/nbproject/build-impl.xml"
23 }
24
25 src_install() {
26         java-pkg_dojar dist/*.jar
27         java-pkg_dolauncher ${PN} --main JarWizard
28 }