dev-util/japi-compliance-checker: new ebuild
[gentoo.git] / dev-util / japi-compliance-checker / japi-compliance-checker-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit git-r3
7
8 DESCRIPTION="Java API compliance checker"
9 HOMEPAGE="https://github.com/lvc/japi-compliance-checker"
10 EGIT_REPO_URI="https://github.com/lvc/japi-compliance-checker.git"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS=""
15
16 DEPEND=">=dev-lang/perl-5"
17 RDEPEND="${DEPEND}
18         >=virtual/jdk-1.8:*
19 "
20
21 src_compile() {
22         :
23 }
24
25 PREFIX="/usr"
26
27 src_install() {
28         mkdir -p "${D}${PREFIX}"
29         perl Makefile.pl -install --destdir "${D}" || die "install failed"
30 }