dev-util/itstool: Switch to PYTHON_MULTI_USEDEP API
[gentoo.git] / dev-util / itstool / itstool-2.0.6-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 PYTHON_REQ_USE="xml"
8
9 inherit python-single-r1
10
11 DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
12 HOMEPAGE="http://itstool.org/"
13 SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
14
15 # files in /usr/share/itstool/its are under a special exception || GPL-3+
16 LICENSE="GPL-3+"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x86-linux"
19 IUSE=""
20
21 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
22
23 RDEPEND="${PYTHON_DEPS}
24         $(python_gen_cond_dep '
25                 dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
26         ')"
27 DEPEND="${RDEPEND}"
28 BDEPEND=""
29
30 DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
31
32 src_test() {
33         :
34         #"${PYTHON}" tests/run_tests.py || die "test suite failed" # Test suite not shipped in tarball
35 }