dev-util/cmake: Bump to version 3.12.0. Removed old.
[gentoo.git] / dev-util / intel-ocl-sdk / intel-ocl-sdk-2.0.31360.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 MY_P=${PN//-/_}_2012_x64
7
8 inherit rpm multilib
9
10 INTEL_CL=usr/$(get_libdir)/OpenCL/vendors/intel/
11
12 DESCRIPTION="Intel's implementation of the OpenCL standard optimized for Intel processors"
13 HOMEPAGE="http://software.intel.com/en-us/articles/opencl-sdk/"
14 SRC_URI="http://registrationcenter.intel.com/irc_nas/2563/intel_sdk_for_ocl_applications_2012_x64.tgz"
15
16 LICENSE="Intel-SDP"
17 SLOT="0"
18 IUSE="tools"
19 KEYWORDS="amd64 -x86"
20
21 RDEPEND="app-eselect/eselect-opencl
22         dev-cpp/tbb
23         sys-process/numactl
24         tools? (
25                 sys-devel/llvm
26                 >=virtual/jre-1.6
27         )"
28 DEPEND=""
29
30 RESTRICT="mirror"
31 QA_EXECSTACK="${INTEL_CL/\//}libcpu_device.so
32         ${INTEL_CL/\//}libOclCpuBackEnd.so
33         ${INTEL_CL/\//}libtask_executor.so"
34 QA_PREBUILT="${INTEL_CL}*"
35
36 S=${WORKDIR}
37
38 src_unpack() {
39         default
40         rpm_unpack ./${MY_P}.rpm
41 }
42
43 src_prepare() {
44         # Remove unnecessary and bundled stuff
45         rm -rf ${INTEL_CL}/{docs,version.txt,llc}
46         rm -f ${INTEL_CL}/libboost*.so
47         rm -f ${INTEL_CL}/libtbb*
48         if ! use tools; then
49                 rm -rf usr/bin
50                 rm -f ${INTEL_CL}/{ioc64,ioc.jar}
51                 rm -f ${INTEL_CL}/libboost*
52         fi
53 }
54
55 src_install() {
56         doins -r etc
57
58         insinto ${INTEL_CL}
59         doins -r usr/include
60
61         insopts -m 755
62         newins usr/$(get_libdir)/libOpenCL.so libOpenCL.so.1
63         dosym libOpenCL.so.1 ${INTEL_CL}/libOpenCL.so
64
65         doins ${INTEL_CL}/*
66 }
67
68 pkg_postinst() {
69         eselect opencl set --use-old intel
70 }