x11-wm/enlightenment: Merge dependency fixes
[gentoo.git] / dev-util / howdoi / howdoi-1.1.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
8 inherit distutils-r1
9
10 DESCRIPTION="A code search tool"
11 HOMEPAGE="https://pypi.python.org/pypi/howdoi"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
21         dev-python/pyquery[${PYTHON_USEDEP}]
22         dev-python/requests[${PYTHON_USEDEP}]
23         dev-python/requests-cache[${PYTHON_USEDEP}]"