dev-util/gyp: Use Python 3.
[gentoo.git] / dev-util / gyp / gyp-99999999999999.ebuild
1 # Copyright 2017-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 PYTHON_COMPAT=(python{3_6,3_7})
6 DISTUTILS_SINGLE_IMPL="1"
7 DISTUTILS_USE_SETUPTOOLS="rdepend"
8
9 inherit distutils-r1
10
11 if [[ "${PV}" == "99999999999999" ]]; then
12         inherit git-r3
13
14         EGIT_REPO_URI="https://chromium.googlesource.com/external/gyp"
15 fi
16
17 DESCRIPTION="GYP (Generate Your Projects) meta-build system"
18 HOMEPAGE="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
19 if [[ "${PV}" == "99999999999999" ]]; then
20         SRC_URI=""
21 else
22         SRC_URI="https://home.apache.org/~arfrever/distfiles/${P}.tar.xz"
23 fi
24
25 LICENSE="BSD"
26 SLOT="0"
27 KEYWORDS=""
28 IUSE=""
29
30 BDEPEND=""
31 DEPEND=""
32 RDEPEND=""
33
34 src_test() {
35         # More errors when DeprecationWarnings enabled.
36         local -x PYTHONWARNINGS=""
37
38         "${PYTHON}" gyptest.py --all --verbose
39 }