902980ba21051011381a68fe0f4db744f56e2034
[gentoo.git] / dev-util / gtk-doc-am / gtk-doc-am-1.32.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME_ORG_MODULE="gtk-doc"
6
7 inherit gnome.org
8
9 DESCRIPTION="Automake files from gtk-doc"
10 HOMEPAGE="https://www.gtk.org/gtk-doc/"
11
12 LICENSE="GPL-2 FDL-1.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15
16 RDEPEND=""
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19         !<dev-util/gtk-doc-${GNOME_ORG_PVP}
20 "
21 # This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
22 RESTRICT="test"
23
24 src_configure() {
25         :
26 }
27
28 src_compile() {
29         :
30 }
31
32 src_install() {
33         insinto /usr/share/aclocal
34         doins buildsystems/autotools/gtk-doc.m4
35 }