dev-util/kdevelop-php: 5.4.5 version bump
[gentoo.git] / dev-util / gource / gource-0.51.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit flag-o-matic
7
8 DESCRIPTION="A software version control visualization tool"
9 HOMEPAGE="https://gource.io/"
10 SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 COMMON_DEPEND="
18         >=dev-libs/boost-1.46:=[threads(+)]
19         >=media-libs/glew-1.5:0=
20         >=media-libs/libpng-1.2:0=
21         media-libs/libsdl2[video,opengl,X]
22         media-libs/sdl2-image[jpeg,png]
23         dev-libs/libpcre:3
24         dev-libs/tinyxml
25         media-libs/freetype:2
26         media-libs/mesa[X(+)]
27         virtual/glu:0
28 "
29 RDEPEND="${COMMON_DEPEND}
30         media-fonts/freefont
31 "
32 DEPEND="${COMMON_DEPEND}
33         >=media-libs/glm-0.9.3
34 "
35 BDEPEND="virtual/pkgconfig"
36
37 DOCS=( README ChangeLog THANKS )
38
39 src_configure() {
40         # fix bug #386525
41         # this enables gource to be compiled against dev-libs/tinyxml[stl]
42         if has_version dev-libs/tinyxml[stl]; then
43                 append-cppflags -DTIXML_USE_STL;
44         fi
45
46         econf \
47                 --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
48                 --with-tinyxml
49 }