dev-util/gource: version bump
[gentoo.git] / dev-util / gource / gource-0.44.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit flag-o-matic
8
9 DESCRIPTION="A software version control visualization tool"
10 HOMEPAGE="http://gource.io/"
11 SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 COMMON_DEPEND="
19         >=dev-libs/boost-1.46:=[threads(+)]
20         >=media-libs/glew-1.5:0=
21         >=media-libs/libpng-1.2:0=
22         media-libs/libsdl2[video,opengl,X]
23         media-libs/sdl2-image[jpeg,png]
24         dev-libs/libpcre:3
25         dev-libs/tinyxml
26         media-libs/freetype:2
27         media-libs/mesa
28         virtual/glu:0
29 "
30 RDEPEND="${COMMON_DEPEND}
31         media-fonts/freefont
32 "
33 DEPEND="${COMMON_DEPEND}
34         virtual/pkgconfig
35         >=media-libs/glm-0.9.3
36 "
37
38 DOCS=( README ChangeLog THANKS )
39
40 src_configure() {
41         # fix bug #386525
42         # this enables gource to be compiled against dev-libs/tinyxml[stl]
43         if has_version dev-libs/tinyxml[stl]; then
44                 append-cppflags -DTIXML_USE_STL;
45         fi
46
47         econf \
48                 --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
49                 --with-tinyxml
50 }