dev-util/gengetopt: Mark ~hppa too
[gentoo.git] / dev-util / gengetopt / gengetopt-2.23.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="A tool to write command line option parsing code for C programs"
8 HOMEPAGE="https://www.gnu.org/software/gengetopt/"
9 SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~hppa ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris"
14 PATCHES=(
15         "${FILESDIR}"/${PN}-2.22.6-docdirs.patch
16 )
17
18 src_prepare() {
19         default
20
21         sed -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' -i configure.ac || die
22         sed -e '/gengetoptdoc_DATA/d' -i Makefile.am || die
23
24         eautoreconf
25 }
26
27 src_configure() {
28         econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
29 }