Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / dev-util / gengetopt / gengetopt-2.22.6.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils autotools
8
9 DESCRIPTION="A tool to write command line option parsing code for C programs"
10 HOMEPAGE="https://www.gnu.org/software/gengetopt/"
11 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 src_prepare() {
19         epatch "${FILESDIR}"/${P}-makefile.patch
20         epatch "${FILESDIR}"/${P}-no-docs.patch
21         epatch "${FILESDIR}"/${P}-docdirs.patch
22         sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
23         eautoreconf
24 }
25
26 src_configure() {
27         econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
28 }
29
30 src_install() {
31         default
32         docompress -x /usr/share/doc/${PF}/examples
33 }