Merge remote-tracking branch 'remotes/operatornormal/gentoo_bug_568874'
[gentoo.git] / dev-util / fhist / fhist-1.19.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit eutils flag-o-matic
8
9 DESCRIPTION="File history and comparison tools"
10 HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
11 SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="GPL-3"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
16 IUSE="test"
17
18 RDEPEND="
19         dev-libs/libexplain
20         sys-devel/gettext
21         sys-apps/groff"
22 DEPEND="${RDEPEND}
23         sys-devel/bison
24         test? ( app-arch/sharutils )"
25
26 src_prepare() {
27         MAKEOPTS+=" -j1"
28         epatch "${FILESDIR}"/${PV}-ldflags.patch
29         append-cflags -fgnu89-inline
30 }