proj/gentoo: Initial commit
[gentoo.git] / dev-util / fhist / fhist-1.16.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 DESCRIPTION="File history and comparison tools"
6 HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
7 SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
8
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~ppc x86"
12 IUSE="test"
13
14 RDEPEND="sys-devel/gettext
15                 sys-apps/groff"
16 DEPEND="${RDEPEND}
17                 test? ( app-arch/sharutils )
18                 sys-devel/bison"
19
20 MAKEOPTS+=" -j1"
21
22 src_compile() {
23         econf
24         emake || die "emake failed"
25 }
26
27 src_test() {
28         emake sure || die "src_test failed"
29 }
30
31 src_install () {
32         emake \
33                 RPM_BUILD_ROOT="${D}" \
34                 NLSDIR="${D}/usr/share/locale" \
35                 install || die "make install failed"
36
37         dodoc lib/en/*.txt || die
38         dodoc lib/en/*.ps || die
39
40         # remove duplicate docs etc.
41         rm -r "${D}"/usr/share/fhist
42
43         dodoc MANIFEST README || die
44 }