dev-util/boost-build: stable 1.71.0 for hppa, bug #689032
[gentoo.git] / dev-util / elfkickers / elfkickers-3.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 MY_PN=${PN/elf/ELF}-${PV}
9 S=${WORKDIR}/${MY_PN}
10
11 DESCRIPTION="collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc"
12 HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
13 SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~hppa ~mips ~sparc ~x86"
18 IUSE="doc"
19
20 DEPEND="app-misc/pax-utils"
21 RDEPEND=""
22
23 PATCHES=(
24         "${FILESDIR}"/${P}-respect-CFLAGS-LDFLAGS.patch
25         "${FILESDIR}"/${P}-create-destdir-path.patch
26         "${FILESDIR}"/add-freebsd-elf-defs.patch
27 )
28
29 src_prepare() {
30         default
31         sed -i -e "s:^prefix = /usr/local:prefix = ${D}:" Makefile \
32                 || die "sed failed"
33 }
34
35 src_compile() {
36         emake CC=$(tc-getCC) all
37 }