dev-util/dwarves: Add ~x86 keyword
[gentoo.git] / dev-util / dwarves / dwarves-1.10_p20160519.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8 inherit multilib cmake-utils python-single-r1
9
10 DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
11 HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
12
13 LICENSE="GPL-2" # only
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug"
17
18 RDEPEND="${PYTHON_DEPS}
19         >=dev-libs/elfutils-0.131
20         sys-libs/zlib"
21 DEPEND="${RDEPEND}"
22
23 if [[ ${PV//_p} == ${PV} ]]; then
24         SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.bz2"
25         S=${WORKDIR}
26 else
27         SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
28 fi
29
30 DOCS=( README README.ctracer NEWS )
31 PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
32
33 src_configure() {
34         local mycmakeargs=( "-D__LIB=$(get_libdir)" )
35         cmake-utils_src_configure
36 }
37
38 src_test() { :; }
39
40 src_install() {
41         cmake-utils_src_install
42         python_fix_shebang "${D}"/usr/bin/ostra-cg \
43                 "${D}"/usr/share/dwarves/runtime/python/ostra.py
44 }