dev-util/cmake: Bump to version 3.12.0. Removed old.
[gentoo.git] / dev-util / drone-cli / drone-cli-0.8.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGO_PN="github.com/drone/drone-cli"
7 EGIT_COMMIT="800d6949bd96847b4d5c400e261b18386ea2226f"
8
9 inherit golang-build golang-vcs-snapshot
10
11 ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 KEYWORDS="~amd64"
13
14 DESCRIPTION="Command-line interface for Drone"
15 HOMEPAGE="https://github.com/drone/drone-cli"
16 SRC_URI="${ARCHIVE_URI}"
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 IUSE=""
20
21 RESTRICT="test"
22
23 RDEPEND="!!<dev-util/drone-0.7"
24
25 src_compile() {
26         pushd src || die
27         GOPATH="${WORKDIR}/${P}"\
28                 go install -ldflags "-X main.version=${PV}.${EGIT_COMMIT:0:7}" ${EGO_PN}/drone || die
29         popd || die
30 }
31
32 src_install() {
33         dobin bin/drone
34         dodoc src/${EGO_PN}/README.md
35 }