Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / dev-util / difffilter / difffilter-0.3.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit autotools-utils
8
9 DESCRIPTION="Filter files out of unified diffs using POSIX extended regular expressions"
10 HOMEPAGE="http://ohnopub.net/~ohnobinki/difffilter/"
11 SRC_URI="ftp://mirror.ohnopub.net/mirror/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 x86 ~amd64-linux"
16 IUSE="doc"
17
18 RDEPEND=">=dev-libs/liblist-2.3.1
19         dev-libs/libstrl
20         dev-libs/tre"
21 DEPEND="doc? ( app-text/txt2man )
22         ${RDEPEND}"
23
24 src_configure() {
25         local myeconfargs=(
26                 $(use_enable doc)
27         )
28
29         autotools-utils_src_configure
30 }