sys-devel/bc: add ~x64-cygwin keyword
[gentoo.git] / dev-util / cwdiff / cwdiff-0.4.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 if [ "${PV}" = "9999" ]; then
7         EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
8         inherit git-r3
9         KEYWORDS=""
10 else
11         SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12         KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
13 fi
14
15 DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
16 HOMEPAGE="https://github.com/junghans/cwdiff"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 IUSE="mercurial"
21
22 DEPEND="sys-apps/help2man
23         sys-apps/coreutils"
24 RDEPEND="
25         sys-apps/sed
26         app-shells/bash
27         app-text/wdiff
28         sys-apps/diffutils
29         mercurial? ( dev-vcs/mercurial )
30         "
31
32 src_install() {
33         emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
34         dodoc README.md
35 }