Merge remote-tracking branch 'github/pr/218'.
[gentoo.git] / dev-util / cwdiff / cwdiff-0.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [ "${PV}" = "9999" ]; then
8         EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
9         inherit git-r3
10         KEYWORDS=""
11 else
12         SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
14 fi
15
16 DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
17 HOMEPAGE="https://github.com/junghans/cwdiff"
18
19 LICENSE="GPL-2"
20 SLOT="0"
21 IUSE="a2ps mercurial"
22
23 DEPEND="sys-apps/help2man
24         sys-apps/coreutils"
25 RDEPEND="
26         sys-apps/sed
27         app-shells/bash
28         app-text/wdiff
29         sys-apps/diffutils
30         a2ps? ( app-text/a2ps )
31         mercurial? ( dev-vcs/mercurial )
32         "
33
34 src_install() {
35         emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
36         dodoc README.md
37 }