Merge remote-tracking branch 'github/pr/218'.
[gentoo.git] / dev-util / cwdiff / cwdiff-0.2.8.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
8 HOMEPAGE="https://github.com/junghans/cwdiff"
9 SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
14 IUSE="a2ps mercurial"
15
16 DEPEND=""
17 RDEPEND="
18         sys-apps/sed
19         app-shells/bash
20         app-text/wdiff
21         sys-apps/diffutils
22         a2ps? ( app-text/a2ps )
23         mercurial? ( dev-vcs/mercurial )
24         "
25
26 src_install () {
27         dobin "${PN}"
28         if use mercurial ; then
29                 insinto /etc/mercurial/hgrc.d
30                 doins hgrc.d/"${PN}".rc
31         fi
32         dodoc README.md
33 }