dev-util/*: Update Manifest hashes
[gentoo.git] / dev-util / creduce / creduce-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 EGIT_REPO_URI="https://github.com/csmith-project/${PN}"
7
8 : ${CMAKE_MAKEFILE_GENERATOR=ninja}
9 inherit cmake-utils git-r3 llvm
10
11 DESCRIPTION="C-Reduce - a plugin-based C program reducer"
12 HOMEPAGE="https://embed.cs.utah.edu/creduce/"
13 SRC_URI=""
14
15 LICENSE="UoI-NCSA"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 COMMON_DEPEND="
21         >=dev-lang/perl-5.10.0
22         >=sys-devel/clang-4:="
23 RDEPEND="${COMMON_DEPEND}
24         dev-perl/Benchmark-Timer
25         dev-perl/Exporter-Lite
26         dev-perl/File-Which
27         dev-perl/Getopt-Tabular
28         dev-perl/Regexp-Common
29         dev-perl/Sys-CPU
30         dev-util/astyle
31         dev-util/indent"
32 DEPEND="${COMMON_DEPEND}"
33
34 llvm_check_deps() {
35         has_version "sys-devel/clang:${LLVM_SLOT}"
36 }