dev-util/creduce: Drop 2.4.0 (requires LLVM 3.7)
[gentoo.git] / dev-util / creduce / creduce-2.7.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 : ${CMAKE_MAKEFILE_GENERATOR=ninja}
7 inherit cmake-utils llvm
8
9 DESCRIPTION="C-Reduce - a plugin-based C program reducer"
10 HOMEPAGE="https://embed.cs.utah.edu/creduce/"
11 SRC_URI="https://embed.cs.utah.edu/creduce/${P}.tar.gz"
12
13 LICENSE="UoI-NCSA"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 COMMON_DEPEND="
19         >=dev-lang/perl-5.10.0
20         sys-devel/clang:4"
21 RDEPEND="${COMMON_DEPEND}
22         dev-perl/Benchmark-Timer
23         dev-perl/Exporter-Lite
24         dev-perl/File-Which
25         dev-perl/Getopt-Tabular
26         dev-perl/Regexp-Common
27         dev-perl/Sys-CPU
28         dev-util/astyle
29         dev-util/indent"
30 DEPEND="${COMMON_DEPEND}"
31
32 LLVM_MAX_SLOT=4