870cfc50f50ba4f715e9b8f008c5f24a606622d8
[gentoo.git] / dev-util / cram / cram-0.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Functional testing framework for command line applications"
11 HOMEPAGE="https://bitheap.org/cram/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 x86"
17
18 python_test() {
19         distutils_install_for_testing
20         "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
21 }