media-sound/asunder: Revbump to handle .desktop file properly.
[gentoo.git] / dev-util / comparator / comparator-2.10.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1 toolchain-funcs
8
9 DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
10 HOMEPAGE="http://www.catb.org/~esr/comparator/"
11 SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 arm ~mips ppc ppc64 sparc x86"
16 IUSE=""
17
18 RDEPEND=""
19 DEPEND="=app-text/docbook-xml-dtd-4.1.2*
20         app-text/xmlto"
21
22 src_prepare() {
23         sed \
24                 -e '/python setup.py install/d' \
25                 -i Makefile || die "sed failed"
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
30         emake comparator.html scf-standard.html
31         distutils-r1_src_compile
32 }
33
34 src_install() {
35         emake ROOT="${D}" install
36         distutils-r1_src_install
37         docinto html
38         dodoc *.html
39 }