Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / dev-util / comparator / comparator-2.10.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 toolchain-funcs
9
10 DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
11 HOMEPAGE="http://www.catb.org/~esr/comparator/"
12 SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 arm ~mips ppc ppc64 ~sparc x86"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="=app-text/docbook-xml-dtd-4.1.2*
21         app-text/xmlto"
22
23 src_prepare() {
24         sed \
25                 -e '/python setup.py install/d' \
26                 -i Makefile || die "sed failed"
27 }
28
29 src_compile() {
30         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
31         emake comparator.html scf-standard.html
32         distutils-r1_src_compile
33 }
34
35 src_install() {
36         emake ROOT="${D}" install
37         distutils-r1_src_install
38         docinto html
39         dodoc *.html
40 }