dev-util/checkbashisms: Bump to version 2.16.13
[gentoo.git] / dev-util / checkbashisms / checkbashisms-2.16.8.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 MY_PN="devscripts"
8 MY_P="${MY_PN}-${PV}"
9
10 inherit eutils
11
12 DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
13 HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
14 SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 # Requires python packages to check tools we don't need anyway
22 RESTRICT="test"
23
24 RDEPEND="dev-lang/perl
25         virtual/perl-Getopt-Long
26         !<dev-util/rpmdevtools-8.3-r1"
27
28 S="${WORKDIR}/${MY_P}/scripts"
29
30 PATCHES=(
31         "${FILESDIR}"/${PN}-2.15.9-command-vV.patch
32 )
33
34 src_prepare() {
35         epatch "${PATCHES[@]}"
36 }
37
38 src_compile() { :; }
39
40 src_install() {
41         newbin ${PN}.pl ${PN}
42         doman ${PN}.1
43 }