Use https by default
[gentoo.git] / dev-util / catalyst / catalyst-2.9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ ${PV} == *9999* ]]; then
8         SRC_ECLASS="git-2"
9         EGIT_REPO_URI="git://anongit.gentoo.org/proj/catalyst.git"
10         EGIT_MASTER="master"
11         EGIT_BRANCH="3.0"
12         SRC_URI=""
13         KEYWORDS=""
14         S="${WORKDIR}/${PN}"
15 else
16         SRC_URI="mirror://gentoo/${P}.tar.bz2
17                 https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
18                 https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
19         KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
20 fi
21
22 PYTHON_COMPAT=( python2_7 )
23
24 inherit distutils-r1 multilib ${SRC_ECLASS}
25
26 DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
27 HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
28
29 LICENSE="GPL-2"
30 SLOT="0"
31 IUSE="ccache doc kernel_linux"
32
33 DEPEND="
34         app-text/asciidoc
35         >=dev-python/snakeoil-0.5.2
36 "
37 RDEPEND="
38         app-arch/lbzip2
39         app-crypt/shash
40         virtual/cdrtools
41         amd64? ( >=sys-boot/syslinux-3.72 )
42         ia64? ( sys-fs/dosfstools )
43         x86? ( >=sys-boot/syslinux-3.72 )
44         ccache? ( dev-util/ccache )
45         kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
46 "
47
48 python_prepare_all() {
49         python_export_best
50         echo VERSION="${PV}" "${PYTHON}" setup.py set_version
51         VERSION="${PV}" "${PYTHON}" setup.py set_version
52 }
53
54 python_compile_all() {
55         # build the man pages and docs
56         emake
57 }
58
59 python_install_all(){
60         distutils-r1_python_install_all
61         if use doc; then
62                 dodoc files/HOWTO.html files/docbook-xsl.css
63         fi
64 }