sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-util / build / build-0.3.10.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit versionator
7
8 DESCRIPTION="A massively-parallel software build system implemented on top of GNU make"
9 HOMEPAGE="https://www.codesynthesis.com/projects/build/"
10 SLOT="0"
11 SRC_URI="https://www.codesynthesis.com/download/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
14 IUSE="examples"
15
16 DEPEND=""
17 RDEPEND="!dev-util/build:0.3"
18
19 src_install() {
20         emake install_prefix="${ED%/}/usr" install
21
22         HTML_DOCS=( documentation/*.{css,xhtml} )
23         einstalldocs
24         dodoc documentation/[[:upper:]]*
25
26         if use examples; then
27                 dodoc -r examples
28                 docompress -x /usr/share/doc/${PF}/examples
29         fi
30 }