dev-util/babeltrace: amd64 x86 stable
[gentoo.git] / dev-util / babeltrace / babeltrace-1.2.4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="A command-line tool and library to read and convert trace files"
10 HOMEPAGE="http://lttng.org"
11 SRC_URI="http://lttng.org/files/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
16 IUSE="test"
17
18 RDEPEND="dev-libs/glib:2
19         dev-libs/popt
20         sys-apps/util-linux
21         "
22 DEPEND="${RDEPEND}
23         sys-devel/bison
24         sys-devel/flex
25         "
26 src_configure() {
27         econf $(use_enable test glibtest)
28 }
29
30 src_install() {
31         default
32         prune_libtool_files --all
33 }