dev-util/ccache: disable nvcc tests
[gentoo.git] / dev-util / atomic-install / atomic-install-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 #if LIVE
7 AUTOTOOLS_AUTORECONF=yes
8 EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
9
10 inherit git-2
11 #endif
12
13 inherit autotools-utils
14
15 DESCRIPTION="A library and tool to atomically install sets of files"
16 HOMEPAGE="https://github.com/mgorny/atomic-install/"
17 SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc static-libs xattr"
23
24 RDEPEND="xattr? ( sys-apps/attr )"
25 DEPEND="${RDEPEND}
26         doc? ( >=dev-util/gtk-doc-1.18 )"
27
28 #if LIVE
29 KEYWORDS=
30 SRC_URI=
31 DEPEND="${DEPEND}
32         >=dev-util/gtk-doc-1.18"
33 #endif
34
35 src_configure() {
36         myeconfargs=(
37                 $(use_enable doc gtk-doc)
38                 $(use_enable xattr libattr)
39         )
40
41         autotools-utils_src_configure
42 }