app-i18n/uim: new upstream release
[gentoo.git] / dev-util / abi-compliance-checker / abi-compliance-checker-2.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A tool for checking backward compatibility of a C/C++ library"
7 HOMEPAGE="http://ispras.linuxbase.org/index.php/ABI_compliance_checker"
8 SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND="dev-lang/perl"
16 RDEPEND="${DEPEND}
17         dev-util/abi-dumper
18         dev-util/ctags"
19
20 src_install() {
21         dodir /usr
22         perl Makefile.pl --install --prefix="${EPREFIX}"/usr --destdir="${D}" || die
23         einstalldocs
24 }